This project has moved and is read-only. For the latest updates, please go here.

Problem installing BrightstarDB on system that does not have visual studio installed

Nov 27, 2014 at 10:10 AM
Hi there. When I run the Brightstar installer on a windows 7 system that does not have Visual Studio installed, and accepting all default install settings, the install completes successfully with the BrightstarDB service registered and running. I can stop and start it with no problems. However when I browse to localhost:8090/brightstar in IE 8 I get the service unavailable error 503 and in Chrome I get the 500 -internal server error : Something went horribly, horribly wrong...
The system has all versions of the .NET Framework (4.0, 3.5, 2.0)
Do I have to register any dependent assemblies (Newtonsoft.Json, Nancy etc ) manually in the GAC for the DB to work?
Any Help appreciated.
Thanks CatInTheHat.
Dec 1, 2014 at 2:43 PM

You shouldn't need to register any assemblies - all the dependencies are contained in the server directory. It looks like Nancy is running (at least when you connect from chrome). It is possible that this is related to ACLs for the endpoint. The BrightstarDB installer automatically registers an ACL for itself on the 8090 port, but perhaps it is clashing with something? See if the info in this SO answer helps.


Dec 15, 2014 at 3:21 PM
Hi Kal,

Sorry for the delay in replying and saying thanks. As it turned out Visual Studio was installed on the box experiencing problems and Brightstar then subsequently worked with no problems. I'm guessing the installation of VS somehow configured IIS with the necessary ACL to allow Brightstar to work. I'm about to try and install Brightstar on a vanilla AWS instance for hosting in IIS and will let you know how that goes.

Thanks again.


May 16, 2015 at 10:24 PM
Edited May 16, 2015 at 10:35 PM
Hi Kal and Rogrer,

I've got similar problems on two out of three boxes, namely http status 500 by Nancy when accessing localhost:8090/brightstar while polaris works. And I've tracked it down to a missing System.Web.Razor.dll on the two boxes without Visual Studio or more precisely without MVC.

copy-ing it from C:\Program Files (x86)\Microsoft ASP.NET\ASP.NET Web Pages\v2.0\Packages\Microsoft.AspNet.Razor.2.0.20715.0\lib\net40 to ...\BrightstarDB\Service and ...\BrightstarDB\wabapp\bin plus restarting the service seems to work on my boxes.

There are two more older discussion items here, where their respective problems seems to have a similar origin. I consider this to be a setup bug, so I'm going to file a new bug item. [Edit] see

May 18, 2015 at 12:12 AM
Thanks for looping me in Lercher

May 18, 2015 at 8:23 AM
Thanks for the report Martin! I've updated the installer so that the System.Web.Razor.dll is included both for the Windows Service version and the IIS version of the BrightstarDB server. I've pushed this out as a 1.10.1 hotfix release so that you can deploy without having to go in and patch the servers afterwards. You can grab the updated installer from
May 18, 2015 at 12:22 PM
Thank you so much.

BTW: Really great software! However, I'm primarily interested in the bare metal SPARQL Service and the RDF Database for Windows PCs. So I'm looking only at a few percent of your awesome work.