This project has moved and is read-only. For the latest updates, please go here.

Visual Studio 2013:: Templates not showing

Nov 23, 2013 at 5:45 PM
I'm using VS 2013 and when I try to create a BrightstarDB entity or context, none of the items are showing up as options.

I've tried using the NuGet install, and then a straight download and install of BrightStarDB. Neither have worked.

Any help would be appreciated.
Nov 23, 2013 at 11:45 PM

I haven't tried things out in Visual Studio 2013 yet as I don't yet have a copy installed anywhere. My guess is that the installer didn't execute the visual studio integration because it didn't detect VS2012 or VS2010 (or it did and it installed for one of those versions but not for VS2013).

What you might be able to do with the straight download is manually install the Visual Studio extensions. After you have installed BrightstarDB you should find a directory inside c:\Program Files\BrightstarDB (or wherever you installed) called "VisualStudio". This contains a .vsi file that you should be able to double-click to install the Visual Studio extensions. Hopefully you should get an option to install into VS2013, but as I say I haven't been able to try that out for myself yet. Please let me know how it goes!



Marked as answer by silverfox1948 on 3/8/2014 at 3:29 PM
Apr 11, 2014 at 3:52 AM
Seems to work when you install the 1.6 manually :)