This project has moved. For the latest updates, please go here.

New to BrightStarDB just install 1.6 / Error on AddImplMapping

Apr 10, 2014 at 2:41 PM
Edited Apr 10, 2014 at 3:58 PM
Good day,

Just download your latest package and try the sample NerdDinner...

Got this error. I have "Object browse" the dll and don't find AddImplMapping... Any hint to make it work.


Error 1 'BrightstarDB.EntityFramework.EntityMappingStore' does not contain a definition for 'AddImplMapping' and no extension method 'AddImplMapping' accepting a first argument of type 'BrightstarDB.EntityFramework.EntityMappingStore' could be found (are you missing a using directive or an assembly reference?) C:\Program Files\BrightstarDB\Samples\Server\NerdDinner\BrightstarDB.Samples.NerdDinner\Models\NerdDinnerContext.cs 29 20 BrightstarDB.Samples.NerdDinner


Let us know waht you found or what I did wrong!

TIA!
André
Apr 10, 2014 at 3:57 PM
I download the previous version and I was able to run the sample.
In BrightStarDB assemblie version 1.5.3.0 I can see 'AddImplMapping'

TIA!
André
Coordinator
Apr 10, 2014 at 9:31 PM
Hi André

It sounds like a packaging error. Most likely the .tt file in that sample is out of date. The best thing to do would be to open the project in Visual Studio, delete the .tt file from the project and then use Add Item to add a Brightstar Entity Context (you should find it under the Visual C# Items) - make sure you give it the same name as the deleted .tt file. I think when it is added it will run and it should generate the context class for you, if it doesn't you just right-click on the .tt file in the solution explorer and select "Run Custom Tool".

Hopefully then it should compile cleanly.

I'll look into why this happened and see if there is something I can do to ensure that all the samples are properly updated when I build the installer.

Cheers

Kal
Apr 11, 2014 at 3:04 AM
No chance it did not work...

I will try the other samples and read the doc further... see if I can properly regenerate the file. Let me know if you generate a new installation package.

Thanks for your help :)

André
Coordinator
Apr 14, 2014 at 9:18 AM
I'll take a look at the packaging issues - maybe I'll need to make a 1.6.1 release to address them.

New releases will always get announced on the blog (http://brightstardb.com/blog/) and usually I'll remember to tweet from @BrightstarDB, so follow either of those to be sure of getting a notification of an update!

Cheers

Kal
May 5, 2014 at 4:52 PM
Work Great now on 1.6.1 ! :) Thanks!