This project has moved. For the latest updates, please go here.

Change timelimit

May 26, 2015 at 6:12 PM
Hi all,

I would like to process some gigabyte of data using Polaris. I guess, my SPARQL query would take many hours. However, there is a 18000ms timelimit.

How can I change or remove this limit?

Thanks in advance and best regards,
C.
Coordinator
May 26, 2015 at 9:50 PM
Hi

I've committed a change to the code to allow these options to be configured in the .exe.config file. The timeouts are specified in milliseconds and are set using appSettings entries like this:
  <appSettings>
    <add key="BrightstarDB.QueryExecutionTimeout" value="250000"/>
    <add key="BrightstarDB.UpdateExecutionTimeout" value="250000"/>
  </appSettings>
You should note that the configuration applies only to embedded store connections. If you are using Polaris to connect to a local file (using the embedded connection type), then the configuration should go in the Polaris.exe.config. For a client-server connection you need to add these settings to the configuration of the server (the BrighstarService.exe.config file, or the web.config file if you have the server deployed in IIS).

This will go into the 1.11 release, or you can grab the code and build it now from GitHub.

Cheers

Kal